• Bannato User Attivo

    Errori stranissimi nell'installazione

    Premesso che non sono nuovo nell'installazione di wordpress, aggiornato alla versione 2.62 incominico ad avere stranissime situazioni con l'editor, non riuscendo a risolvere il problema decido di reinstallare wp partendo da zero cancellando anche il db, ricreato il tutto, db e file config.php, da questo momento inizia la via crucis, inviato il /wp-admin/installp.php mi viene fuori in alto, insieme alla schermata di benvenuto il seguente errore:

    
    Warning: Cannot modify header information - headers already sent by (output started at /home/uf4ibmh9/domains/divietodispam.com/public_html/wp-config.php:1) in /home/uf4ibmh9/domains/divietodispam.com/public_html/wp-admin/install.php on line 12

    controllo la linea 12 del file imputato e trovo questo

    header( 'Content-Type: text/html; charset=utf-8' );

    imperterrito continuo nella procedura di creazione tabelle invio il comando installa viene fuori il classico "successo" ma sempre con l'errore presente nella parte alta di cui prima tosto come non mai faccio il "vai avanti" l'errore in alto a dx cambia in un bel

    
    Warning: Cannot modify header information - headers already sent by (output started at /home/uf4ibmh9/domains/divietodispam.com/public_html/wp-config.php:1) in /home/uf4ibmh9/domains/divietodispam.com/public_html/wp-login.php on line 267

    Warning: Cannot modify header information - headers already sent by (output started at /home/uf4ibmh9/domains/divietodispam.com/public_html/wp-config.php:1) in /home/uf4ibmh9/domains/divietodispam.com/public_html/wp-login.php on line 279

    inserisco "admin" e la password arrivederci e buona notte a tutti la procedura si blocca e mi ritrovo vari errori al wp-login.php alle righe 269 e 270 ed errori al wp-includes/pluggable.php alle righe 595 596 597 770
    Non so dove sbattere la testa avrò installato e reinstallato wp non so quante volte cancellando e ricreando più volte il db
    Aiutooooooooooooooooo
    p.s.
    Sono anche passato ad una precedente versione ma sempre lo stesso risultato, sarà mica un errore del db? e le uniche cose che ho modificato nel file config è quello di aver inserito il "secret_key" e qver cambiato il table_prefix da wp_ a wp_altricaratteri_


  • User Attivo

    prova a riscaricare il file di wordpress e di reinstallarlo...


  • User Attivo

    Assicurati che prima di cariare i files della versione nuova, hai cancellatto tutti quelli della versione vecchia TRANNE la cartella wp-content
    Prova anche a commentare la riga header( 'Content-Type: text/html; charset=utf-8' ); nel wp-config.php, (tirala via o commentala). Io in una delle mi installazioni la ho dovuta togliere perchè mi creava problemi ed avevo letto che poteva essere la soluzione in quanto nelle versioni precedenti il charset NON veniva definito in quel file.


  • Bannato User Attivo

    @jkkl said:

    prova a riscaricare il file di wordpress e di reinstallarlo...
    Fatto decine di volte incluso la cancellazione e la ricreazione del db.


  • Bannato User Attivo

    @Jantima said:

    Assicurati che prima di cariare i files della versione nuova, hai cancellatto tutti quelli della versione vecchia TRANNE la cartella wp-content
    Non ho fatto un aggiornameto, wp si era inceppato cercando di sistemare quel maledetto editor, peraltro non riuscito, per il problema della visualizzazione html fissa perennemente.
    Prova anche a commentare la riga header( 'Content-Type: text/html; charset=utf-8' ); nel wp-config.php, (tirala via o commentala). Io in una delle mi installazioni la ho dovuta togliere perchè mi creava problemi ed avevo letto che poteva essere la soluzione in quanto nelle versioni precedenti il charset NON veniva definito in quel file.
    Sai che non vedo nel conifg.php quanto tu dici? Anzi te lo posto così guardi:


    <?php
    // ** Impostazioni MySQL ** //
    define('DB_NAME', 'xxxx'); // Nome del database
    define('DB_USER', 'xxxx'); // Il vostro username MySQL
    define('DB_PASSWORD', 'xxxx'); // ...e la password
    define('DB_HOST', 'localhost'); // al 99% non dovrebbe esserci necessità di modificare questo valore
    define('DB_CHARSET', 'utf8');
    define('DB_COLLATE', '');
    define('SECRET_KEY', 'qD!:FOEbDW7H[=F)04
    @D;#:iOi2'`$bW<"9DG;_)0Y]IFRl)\;cc|3*3t;sEO!9');

    // Modifica ciascuna KEY con una diversa frase unica. Non la si dovrà ricordare in seguito,
    // quindi crearne di lunghe e complesse. E' possibile visitare htttp://api.wordpress.org/secret-key/1.1/
    // per avere una frase generata automaticamente oppure crearne una manualmente.
    // Ciascuna chiave dovrebbe avere una frase differente.
    define('AUTH_KEY', 'fi=E09)cIT2Sm-p!N3qugCP='B~<[%a)[email protected]#/^QzD[R-6\\,x$y0?osZ2W>G62>M');
    define('SECURE_AUTH_KEY', '6*;p1?Bmo/T~bD4.E7Hr{Y2v^s(U1*tcF{$1|e=!%hGsU8Kn{Lsw=A1oK#){BR,c');
    define('LOGGED_IN_KEY', '/1I>c9D>I#\id!PeK!9~,nyF(j5x6[LBz4h9mJ.o_0w$d%\<km6B EGi{n#@Al|f');

    // E' possibile avere installazioni multiple su un singolo database assegnando a ciascuna un prefisso univoco
    $table_prefix = 'wp_dc700ld_'; // Solo numeri, lettere e sottolineature!!

    // Modificate questa voce per localizzare WordPress. Occorre che sa presente
    // il file .MO della lingua scelta all'interno di wp-content/languages.
    // Ad esempio, installare de.mo in wp-content/languages ed impostare WPLANG a 'de'
    // per abilitare il supporto alla lingua Tedesca.
    define ('WPLANG', 'it_IT'); // Già impostato per la lingua italiana

    /* Niente altro, configurazione terminata! Buon blogging. */

    if ( !defined('ABSPATH') )
    define('ABSPATH', dirname(FILE) . '/');
    require_once(ABSPATH . 'wp-settings.php');
    ?>


    qualc'uno palesava anche sugli spazi asserendo che
    "E l'errore del php è proprio quello:
    output started at /home/uf4ibmh9/domains/divietodispam.com/public_html/wp-config.php:1
    Nella riga uno invii dei caratteri", ma il file che vedi è quello che ho estratto, dovrò mica eliminare qualsiasi spazio fra le righe?
    Ciao
    p.s.
    Avrai qualche file config.php sotto mano da potermi inviare, così vado sul sicuro.


  • User Attivo

    Scusami, la riga che ti dicevo di provare di togliere in realta' e':

    define('DB_CHARSET', 'utf8');

    [mi ero confusa con l'altra che avevi postato]

    Per la visualizzazione dell editor, non so se lo sai, ma nelle versioni nuove di wp, oppure quando si aggiorna, bisogna andare nelle preferenze dell utente e ri-abilitare il wysiwyg (editor) [Edit User -> Personal Options -> Visual Editor]

    Per la questione degli spazi, no non devi togliere spazi, ma in effetti l'errore "headers already sent by (output started at /home/uf4ibmh9/domains/divietodispam.com/public_html/wp-config.php:1" mi fa pensare ad un errore che capita se all inizio del file hai una riga vuota. Magari assicurati di non avere spazio all inizio del file config-php

    e questo che non vada a capo:

    define('SECRET_KEY', 'qD!:FOEbDW7H[=F)04
    @D;#:iOi2'`$bW<"9DG;_)0Y]IFRl)\;cc|3*3t;sEO!9');

    ma che sia cosi':
    define('SECRET_KEY', 'qD!:FOEbDW7H[=F)[email protected];#:iOi2'`$bW<"9DG;_)0Y]IFRl)\;cc|3*3t;sEO!9');