Dopo 16 anni di attività del Forum GT, oggi, da quello stesso forum, nasce una nuova Community: Connect.gt
Attualmente siamo in fase Alpha 0.1
SCOPRI TUTTE LE NOVITÀ CLICCANDO QUI

Oppure Lascia un feedback, Segnala un bug, Suggerisci miglioramenti o Togliti un dubbio!
  • User Newbie

    Problemi con helicon isapi_rewrite3 sotto IIS 6

    Ciao,
    ho installato con successo vbseo perchè gli url vengono effettivamente riscritti ma qualsiasi pagina io chieda non viene mostrato a video alcun risultato.
    Ho provato a debuggare il file vbseo.php e mi sono accorto che la variabile $vbseo_url_ è sempre settata a 'vbseo.php' e quindi lo script esce.
    Credo a questo punto che il problema possa essere circostritto o alle regole dell'url rewriter o a qualche problema nella configurazione di php ma non so davvero da che parte prendere.
    Di seguito posto le regole che ho usato

    
    RewriteCond %{HTTP:Host} ^www\.miodominio\.it$
    RewriteRule ^/forum/((urllist|sitemap).*\.(xml|txt)(\.gz)?)$ /forum/vbseo_sitemap/vbseo_getsitemap.php?sitemap=$1 
    
    RewriteCond %{HTTP:Host} ^www\.miodominio\.it$
    RewriteCond %{REQUEST_URI} ^/forum/(?!avatars|attachments|iconimages).*$
    RewriteRule ^([^\?]*\.(?:gif|swf.*|jpg|png|css|xml|js|htm|txt|zip)(?:\?(.*))?)$ $1 [NC,L]
    
    RewriteCond %{HTTP:Host} ^www\.miodominio\.it$
    RewriteCond %{REQUEST_URI} ^/forum/(?!admincp/|modcp/|clientscript/|cpstyles/|images/|search\.php).*$
    RewriteRule ^/forum/(.+?)(?:\?(.*))?$ /forum/vbseo.php 
    
    

    Ma devo per caso caricare anche ioncube loader?


  • Super User

    Hai seguito esattamente le istruzioni?

    Che versione di vbseo hai installato?
    Hai caricato i file in modalità binary?


  • User Newbie

    Ciao,
    la versione di vbseo installata è la 3.2.0 mentre vBulletin è la versione 3.7.
    Io ho seguito passo passo le istruzioni ma nulla da fare.
    Ho aperto anche un ticket sul sito ufficiale e mi hanno consigliato di cancellare le regole del rewriter di Helicon e di utilizzare il file .htaccess ma nulla è cambiato.
    La cosa che mi lascia perplesso è che le regole sembrano andare ma quando il file vbseo.php viene richiamato si ferma subito perchè temo non gli arrivino i parametri corretti.


  • Super User

    Purtroppo non so aiutarti.
    Sicuramente ti hanno consigliato bene ad usare i setting di vbseo.
    Hai controllato i permessi sulle cartelle?

    Per capirci, quando richiami una pagina vien fuori bianca o proprio non raggiungibile?


  • User Newbie

    La pagina veniva fuori completamente bianca.
    Comunque sia ho risolto: le regole del rewriter allegate al pacchetto di installazione erano errate: mancava un pezzo.


  • Super User

    Ok, son contento tu abbia risolto 😉