• User Newbie

    non mi funziona il mex diretto nel sito... HELP !!

    Ciao a tutti. Sono nuovo in questo forum e spero che almeno voi mi potete aiutare... Sul mio sito www.cappalex.it non mi funziona il mex diretto e non riesco a capire xè. Al pulsante invia ho associato l' as

    on (press) {
    if (inputName ne "" and inputEmail ne "" and inputSubject ne "" and inputMessage ne "") {
    gotoAndPlay("valid");
    sendAndLoad("sendmail.php", 0, "POST");
    } else {
    gotoAndPlay("invalid");
    }
    }

    Nello script sendmail.php ho inserito questo

    <?

    $adminaddress = "[email protected]";

    $siteaddress ="http://www.cappalex.it";

    $sitename = "cappalex.it";

    $date = date("m/d/Y H:i:s");

    if ($REMOTE_ADDR == "") $ip = "no ip";
    else $ip = getHostByAddr($REMOTE_ADDR);

    IF ($action != "")
    {
    mail("$adminaddress","Enquiry from www.yourwebsite.com",
    "ENQUIRY FROM WEBSITE EMAIL FORM"
    Name: $inputName
    Email: $inputEmail
    Subject: $inputSubject
    Message: $inputMessage

    Logged Info :
    Using: $HTTP_USER_AGENT
    Hostname: $ip
    IP address: $REMOTE_ADDR
    Date/Time: $date","FROM:$adminaddress");

    mail("$vemail","Grazie per aver visitato $sitename","La vostra e-mail sara' visionata al piu' presto ,"FROM:$adminaddress");

    $sendresult = "Done!";
    $send_answer = "answer=";
    $send_answer .= rawurlencode($sendresult);

    // echo "$send_answer";

    }

    ?>
    Mi dite per favore dove sbaglio??

    Grazie a tutti...

    cappalex :fumato:


  • User Attivo

    Scusa,
    non ho capito bene cosa non ti funziona...

    Ho dato uno sguardo veloce allo script...

    Penso tu ti riferisca alla funzione POST per inviare il messaggio all'indirizzo di posta elettronica, ma posso aver capito male.
    Comunque, in questo passo dello script
    sendAndLoad("sendmail.php", 0, "POST");

    prova a mettere la path diretta (non quella relativa) cioè del genere: http://www.miosito.it/path/sendmail.php

    E' solo un'idea. Provaci.

    ciao 😉


  • User Newbie

    Ciao arcana. Quello che mi hai scritto ho già provato a farlo e non cambia niente. Il mio problema è che non mi invia il messaggio dal sito nella sezione (vuoi parlare con me). L'animazione viene eseguita correttamente xò è come se non considerasse lo script sendmail in php. Mi hanno detto che devo inserire il sendAndLoad ma come vedi ho provato ma il problema rimane.

    :arrabbiato: 😢 😞


  • User Attivo

    Di solito, quando voglio inviare le informazioni alla pagina PHP tramite un bottone, faccio così... questo l'esempio di script:

    square_btn.onRelease = function(){
    //setta il numero inviato
    sNum_lv.sentNum = num_txt.text;
    //invia e riceve i dati
    sNum_lv.sendAndLoad("http://MIOSERVER/squareNum.php", sNum_lv, "POST");

    Come avrai notato, uso "onRelease" per il bottone e non "onPress"... :bho:

    ciao :mmm:


  • User Newbie

    Va beh arcana xò non può essere quello il problema dal momento che
    on(release) si associa al pulsante per determinare l'esecuzione dell'azione al "rilascio" dello stesso; on(press) alla pressione...

    Boh??!... non capisco... ma gli utilizzatori actionscript sono tutti impegnati?? :bho:


  • Super User
    gotoAndPlay&#40;"valid"&#41;;
    sendAndLoad&#40;"sendmail.php", 0, "POST"&#41;; 
    

    Se mandi ad un altro frame con il gotoandplay lo script seguente non credo venga eseguito...

    Per controllo metti un trace("ciao"); dopo il gotoandplay e vedi (testando il filmato direttamente in flash) se viene eseguito. Si apre una finestra con dentro la scritta ciao.

    Cmq lo script è concepito non benissimo, perchè se lo script php ha un problema qualsiasi il messaggio non viene inviato ma il flash va ugualmente al frame valid. Dovresti leggere la risposta dal php prima di dare messaggi ok/non ok...

    ciao