Dopo 16 anni di attività del Forum GT, oggi, da quello stesso forum, nasce una nuova Community: Connect.gt
Attualmente siamo in fase Alpha 0.1
SCOPRI TUTTE LE NOVITÀ CLICCANDO QUI

Oppure Lascia un feedback, Segnala un bug, Suggerisci miglioramenti o Togliti un dubbio!
  • User Attivo

    Guida: MOD_REWRITE JOOMLA

    esistono tanti prodotti per rendere puliti gli url, il migliore a pagamento è senza dubbio SEF_ADVANCE con il quale alcuni risultati li possiamo notare sul sito di skype.

    il migliore non a pagamento è decisamente ARTIO JoomSEF prodotto da un'azienda ceca. JoomSEF lo uso con successo anche sul componente VirtueMart.

    vediamo come si installa:

    aprite l'amministrazione di joomla e cliccate su installa componenti nel menu in alto, dopodichè fornite il percorso nel quale avete salvato il vostro componente e cliccate su "carica file e installa".

    una volta fatto questo vi verrà chiesto di creare un file .htaccess, quindi sul vostro PC create un file con notepad e chiamatelo htaccess.txt e all'interno incollateci questo:

    Options FollowSymLinks

    mod_rewrite in use

    RewriteEngine On

    Togli il seguente commento se l'url del server

    non è direttamente relazionato al file path

    Aggiorna le tue directory joomla (just / for root)

    RewriteBase /

    ########## Begin Standard SEF Section

    Tutte le linee qui sotto sono richieste se

    sul server hai cartelle con nome content o component

    Se non hai cartelle con questo nome, lascia il commento

    #RewriteCond %{REQUEST_FILENAME} !-f
    %{REQUEST_FILENAME} !-d
    %{REQUEST_URI} ^(/component/option,com) [NC,OR] ##optional - see notes##
    %{REQUEST_URI} (/|.htm|.php|.html|/[^.]*)$
    #RewriteRule ^(content/|component/) index.php

    ########## E-fine

    ########## inizio

    RewriteCond %{REQUEST_URI} (/|.htm|.php|.html|/[^.])$
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule (.
    ) index.php

    ########## fine

    il file creato mettilo nella root principale del tuo sito sul server dopodichè torna nell'amministrazione del tuo sito. Clicca su "Configurazione Globale" e clicca poi nell'ultimo bottone a destra denominato appunto SEO e in corrispondenza di "Search Engine Friendly URLs:" metti si. A questo punto ti verrà chiesto di rinominare il file che hai appena caricato in .htaccess e il gioco è fatto..

    se non piacciono gli url creati di default si possono totalmente personalizzare...

    :ciauz:


  • Community Manager

    Grazie per aver messo questa guida, molto utile.

    Appena siamo pronti la aggiungo al rilievo 🙂


  • User Attivo

    salve,
    uso da poco joomla e sto provando ARTIO joomsef e ho un dubbio creando il sitemap con joomap, praticamente mi ritrovo link diversi che puntano alla stessa pagina es:
    www.pippo.com/film.html
    www.pippo.com/film-2.html
    a quanto ho capito joomsef aggiunge un numero alla fine per ogni collegamento che punta sulla pagina ma questo non rischia di penalizzare l'indicizzazione perche google trova piu pagine uguali con nome diverso?
    grazie


  • Super User

    ciao bronco, di questa cosa ne stavo discutendo con un utente nel forum ufficiale di joomla e stavamo cercando di capire da cosa dipendesse, ma per mancanza di tempo ho dovuto abbandonare la ricerca...prova a fare una ricerca li, magari hanno continuato il post.


  • User Attivo

    grazie della risposta, ho provato a guardare un po in giro ma non ho ancora risolto, a quanto ho capito il problema sta nella versione di joomla 1.0.12 ma per quel poco che ne capisco di inglese non ho trovato soluzioni.
    ora ho sonno e ci rinuncio domani proverò a guardare meglio.


  • User Attivo

    il problema che tu riporti non è solo di joomla, ma anche di mambo , quindi alla fine il problema è del componente che mette alla fine il "numerino" .... unica cosa è vedere o di fare la modifica al componente o di chiederla ... sinceramente in questo periodo per me è meglio la seconda 😛


  • User Attivo

    con google ci sono molte discussioni che parlano del problema ma le poche soluzioni che ho trovato non funzionano, io di php non me ne intendo quindi non so piu che fare, lo trovo troppo penalizzante per i motori di ricerca avere una pagina con tanti nomi diverse, non so se è meglio disattivare artio o no, oppure tornare a una versione precedente di joomla ma non mi esalta molto questa ipotesi.


  • Super User

    Non sono un fenemono nel SEO, ma io sul mio sito, mi sono fatto tutto da solo, ho joomla 1.0.1.2 e artio attivo, e problemi di penalizzazione non ne ho mai avuti...sono sempre in 1° pagina, fra il 1° e il 5° posto, per il 70% delle mie key, quindi al momento, non lo vedo come problema.


  • User

    ciao,
    avevo già installato JoomSEF, senza attivarlo. Ora ho provato ad attivarlo, seguendo le istruzioni,in locale, ed ho i seguenti risultati:

    ho perso per strada qualche passaggio?
    Grazie,
    Fabio


  • Community Manager

  • User

    se avessi dei problemi con i chmod e non posso cambiare le impostazione della configurazione globale, come faccio in manuale, cioè da un blocco note, a cambiare la dicitura del search friendly url del seo? devo aggiungere una stringa o modificare gia una esistente??


  • Super User

    @jolpat said:

    se avessi dei problemi con i chmod e non posso cambiare le impostazione della configurazione globale, come faccio in manuale, cioè da un blocco note, a cambiare la dicitura del search friendly url del seo? devo aggiungere una stringa o modificare gia una esistente??

    Ti ho risposto nell'altro post.;)


  • User Attivo

    robot_dika : diceva se non vi piacciono le url possiamo anche personalizzarle........puoi darmi una mano....non voglio installare altri componenti per l'url rewrite.....come possiamo sfruttare al meglio......l'htaccess di joomla????


  • User Newbie

    ho seguito tutte le indicazioni ma perchè ricevo sempre errore 500? .. non riesco proprio a capire.. sto lavorando in locale.. dipende da quello?..
    ho decommentato questa riga # RewriteBase /
    ho inserito la cartella dove risiede il sito.. ma dove sbaglio ??? son giorni che provo ma non riesco a farlo funzionare......
    helphelphelphelp 🙂


  • User Attivo

    @dubbisudubbi said:

    ho seguito tutte le indicazioni ma perchè ricevo sempre errore 500? .. non riesco proprio a capire.. sto lavorando in locale.. dipende da quello?..
    ho decommentato questa riga # RewriteBase /
    ho inserito la cartella dove risiede il sito.. ma dove sbaglio ??? son giorni che provo ma non riesco a farlo funzionare......
    helphelphelphelp 🙂

    si certo...il rewrite non funziona in locale


  • User

    io uso joomla .. siccome non mi fanno sul server (altervista) modificare htacces..(non ho soldi) con il tuo metodo posso installarlo già come .htacces
    ciao grazie


  • User Attivo

    @forziere said:

    io uso joomla .. siccome non mi fanno sul server (altervista) modificare htacces..(non ho soldi) con il tuo metodo posso installarlo già come .htacces
    ciao grazie

    purtroppo se non hai il permesso di modificare l htaccess non riesci a modificare le url...


  • User Attivo

    sh404SEF fa il rewrite anche senza htaccess ma aggiunge "index.php" alle url, le url diventano: http: //www .miosito.it/index.php/sezione/categoria/articolo-scritto.html


  • User

    scusate io con joomla ho rinominato il file.. che avevo già sulla directory ma quello vecchio lo devo levare (.txt) .
    appena fatto mi ha dato errore sul sito il sh404sef.. mi dice che gli manca qlc nella scrittura?? così il sito si è fermato cosa devo fare???? aiutatemi!!!!!!!!!!


  • User Attivo

    alcuni hosting richiedono che venga commentata la riga: Options +FollowSymLinks aggiungendo # davanti. Non sò se è il tuo caso.