Dopo 16 anni di attività del Forum GT, oggi, da quello stesso forum, nasce una nuova Community: Connect.gt
Attualmente siamo in fase Alpha 0.1
SCOPRI TUTTE LE NOVITÀ CLICCANDO QUI

Oppure Lascia un feedback, Segnala un bug, Suggerisci miglioramenti o Togliti un dubbio!
  • User

    Problemi con le descrizioni su Google

    Ciao ragazzi,
    ho notato tempo fa che alcune pagine del mio sito, indicizzate su Google, presentavano nella descrizione alcuni caratteri strani. Con il passare del tempo i vari caratteri accentati delle restanti pagine indicizzate sono stati sostituiti con quelli speciali.

    La codifica utilizzata è la UTF-8 e non capisco come mai ogni carattere accentato visualizzato nella descrizione delle pagine del sito indicizzate sono mostrati male.

    Vorrei sistemare la faccenda, non digerisco quel tipo di caratteri.

    A cosa è dovuta questa sostituzione? Come si può risolvere?

    Grazie mille in anticipo

    P.S. provate a guardare facendo site:www . girandoilmondo . it


  • Moderatore

    Ciao GirandoilMondo,

    hai provato con le entità html, per esempio invece del simbolo ??


  • Moderatore

    Ciao GirandoilMondo,

    hai provato con le entità html, tipo usare € invece del simbolo ? , o è invece della e accentata, etc.?


  • User

    Nelle pagine scritte in PHP ho sempre inserito è e compagnia, ed infatti la visualizzazione sulle pagine va bene, non ho nessun problema. Anche negli articoli, impostati da wordpress con codifica UTF-8 non ho problemi.

    Il problema si verifica solo ed esclusivamente nelle descrizioni degli articoli visualizzate su Google e non riesco a capire perchè. Non mi era mai successo prima 😮


  • User

    Forse ho trovato!!
    Tempo fa avevo impostato nell'header alcune righe:

    <meta name="DC.title" lang="it" content="Girando il Mondo" />
    <meta name="DC.creator" content="Giannotti Fabio" />
    <meta name="DC.subject" content="Voli,LowCost,Guide,Itinerari,Viaggi" />
    <meta name="DC.publisher" content="girandoilmondo.it" />
    <meta name="DC.language" scheme="DCTERMS. ISO639-2" content="it" />
    <meta name="DC.format" scheme="DCTERMS.IMT" content="text/html" />
    <meta name="DC.type" scheme="DCTERMS.DCMIType" content="Text" />
    

    Probabilmente a dare problemi è ISO639-2. Fattibile? Ora l'ho rimosso....


  • Moderatore

    Mi sembra che il problema riguardi soprattutto il simbolo ?, e io nel sorgente della pagina non trovo € ma ?.
    Ho provato a vedere altre pagine mie dove ho l'entità nelle descriptions e nel sorgente le vedo effettivamente come entità per esteso.

    Sei sicuro di avere le entità nelle descriptions per quanto riguarda l'euro?

    EDIT: ho inviato questa risposta prima di leggere il post che intanto stavi scrivendo tu, sul quale comunque non saprei dire, riguardo al metatag citato, se può essere quello il problema. Fai qualche prova e facci sapere.